You are not logged in.

Dear visitor, welcome to QtForum.org. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, July 28th 2009, 8:26am

qtcreator.exe Failed to start because application configuration is incorrect

So I had the LGPL version of Qt working on my laptop using the mingw compiler that came with the installer. I made the mistake of doing some housekeeping and removing some unneeded (and unrelated) applications from the Add/Remove Programs window, and for some (unknown) reason, Qt now fails to start:

Source code

1
2
c:\qt\2009.03\bin\qtcreator.exe
This application has failed to start because the configuration is incorrect.  Reinstalling the application may fix this problem.

I've tried reinstalling Qt, reinstalling the applications I removed then reinstalling Qt, but qtcreator now always produces this error when I try to start it.

Has anyone come across this error message before? Does anyone know why this error message is produced or what I need to do to get qtcreator to work again?

This post has been edited 2 times, last edit by "aFiveH" (Jul 28th 2009, 8:34am)


2

Tuesday, July 28th 2009, 8:43am

Don't know what the problem was, but uninstalling Qt, deleting the residual "c:\qt\2009.03" folder, and hacking references to Qt/Trolltech out of the registry (using "2009.03" search) appears to have solved the problem.